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This guide provides the basic information 
required to set up and begin using your 
new SMART-AG, a combined L1 GNSS 
receiver and antenna with Emulated 
Radar (ER) output. The SMART-AG also 
features optional Bluetooth® wireless 
connectivity and tilt compensation.

For more detailed information on the installation and operation of 
your receiver, refer to the SMART-AG and OEMV® user 
manuals. These manuals are available on NovAtel's website at:

www.novatel.com/support/firmware-software-and-manuals/ 

SMART-AG BOX CONTENTS

In addition to this quick start guide, the following are provided 
with your SMART-AG:

• 1 - CD containing: 

• An installation program for the NovAtel PC Utilities

• Product documentation

• 1 - User Manual postcard for requesting printed manuals

• Mounting Plate

• 1 - SMART-AG cable for power and communications 
(NovAtel part number 01018256)

ADDITIONAL EQUIPMENT REQUIRED

The following additional equipment is required for a basic setup:

• A Windows-based PC with an RS-232 DB-9 port

• A battery connection (+8 to +36 V DC)

INSTALLING THE PC UTILITIES

Before setting up your SMART-AG, install NovAtel’s PC Utilities 
on the Windows-based computer that you will use to 
communicate with it. This computer must have an RS-232 DB-9 
port.

1. Start up the computer.

2. Insert the accompanying CD into the CD-ROM drive of the 
computer. 

3. Select Install the OEMV PC Utilities from the window that is 
automatically displayed. If the window does not 
automatically open when the CD is inserted, select Run from 
the Start menu and select the Browse button to locate 
Setup.exe on the CD drive.

4. Install the PC Utilities by advancing through the steps 
provided in the NovAtel GPS PC Utilities setup program.

SETTING UP YOUR SMART-AG

Complete the steps below to connect and power your receiver.

1. Mount the SMART-AG on a secure, stable structure with an 
unobstructed view of the sky.

2. Connect the SMART-AG cable to the SMART-AG.

3. Connect the SMART-AG to a DB-9 serial port on the PC.

4. Provide power to the SMART-AG as follows: 
Connect the red wire of the cable (connector pin 14) to the 
positive side of a 12 or 24V vehicular power circuit (or 
equivalent) protected by a 5A fast blow fuse (user supplied). 
NovAtel recommends an automotive blade-type fuse, rated 
for 5A and with an operating voltage of more than 36V 
(recommended fuse part numbers are in the SMART-AG 
User Manual).
Connect the black wire of the cable (connector pin 9) to the 
negative side of the power circuit. 
If a SMART-AG cable (NovAtel part number 01018256) is 
not used, a minimum wire size of 0.5 mm/ 20AWG is 
required. 

SMART-AG LEDS

The LEDs on the SMART-AG represent these categories:

SMART-AG CABLE

The SMART-AG cable (NovAtel part number 01018256) has two 
DB-9 connectors, see Figure 1. One can accommodate a 
computer serial (RS-232) communication port and the other can 
connect to a modem or radio transmitter to receive differential 
corrections (refer to your user-supplied modem or radio 
transmitter information for its connectors).

At the other end is a 14-pin connector, see Figure 1. 

In addition, there are a number of bare wires where the outer 
insulation is cut away but the wires beneath are intact. See Table 
2 for the cable pinouts. 

The SMART-AG cable provides a means of supplying power 
from a battery while operating in the field. The bare wires (red for 
positive and black for negative) can then be tied to a battery 
supply capable of at least 5 W.

The SMART-AG cable is RoHS compliant.

QUICK START GUIDE

 To access and download the most current version of our 
OEMV PC Utilities, go to the Support page of the NovAtel 
web site at www.novatel.com.
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 Table 1:  SMART-MR15 LED Behavior

Red Yellow Green
Condition

Off Off Off Power is not available

On Off Off Power available but no satellites are tracking 
yet

On Flashinga

a. Flashing means that the LED is turning on and off at a 1 Hz rate - 0.5 seconds on 
and 0.5 seconds off.

Off Tracking at least one satellite but not a valid 
position

On On Off Position valid in basic autonomous mode

On On Flashinga
An SBAS signal is being tracked but 
sufficient data for SBAS operation has not yet 
been received

On On On Position valid in an enhanced accuracy mode 
(WAAS/EGNOS/MSAS/DGPS or RTK)

http://www.novatel.com/support/firmware-software-and-manuals/


 Figure 1:  14-pin and DB-9 Pin Numbers

ESTABLISHING RECEIVER COMMUNICATION

To open a serial port to communicate with the receiver, complete 
the following steps.

1. Launch Connect from the Start menu folder specified during 
the installation process. The default location is Start | 
All Programs | NovAtel PC Software | NovAtel Connect.

2. Select New from the Device Menu.

3. Enter a name for the Connection setup.

4. Select Serial from the Type list.

5. Select the computer port to which the SMART-AG is 
connected, from the Port list.

6. Set the COM port for the receiver to communicate through.

7. Select 115200 from the Baud Rate list. 

8. Ensure the Hardware Handshaking box is not checked and 
click the OK button.

9. From the Device menu select Open Connection.

10. Select the Open button to open SMART-AG 
communications.

Connect establishes the communication session with the 
receiver and displays the progress. Once connected, the 
progress box disappears and several windows open, including 
the Console window. Connect is now ready for use to view status 
information, enter commands or log data.

USING NOVATEL CONNECT

Connect provides access to key information about your receiver 
and its position. The information is displayed in windows 
accessed from the View menu. For example, select Position 
Window from the View menu to display the position solution of 
the receiver. To show details of the GNSS and geostationary 
(SBAS) satellites being tracked, select the a Tracking Status 
Window from the View menu. Select Help from the main menu 
for more details on Connect, its windows and features.

DETERMINING WHEN THE POSITION IS VALID

When the receiver has a valid position, the Solution Status field 
in Connect’s Position window shows Computed.

ENTERING COMMANDS

The SMART-AG uses a comprehensive command interface. 
Commands can be sent to the receiver using the Console 
window in Connect, which is opened from the View menu. Enter 
commands in the text box at the bottom of the Console window.

The OEMV Family Quick Reference Guide, provided on the CD 
and available on the NovAtel website, provides comprehensive 
information about available commands. The SMART-AG User 
Manual provides information on a subset of these commands; in 
particular, the ones commonly used on the SMART-AG.

 Table 2:  SMART-AG Cable Wire Colors

Wire Color Signal Name 14-pin 
(J1) 

DB-9 
(J2) 

DB-9 
(J3) Label

Red COM1_TXD 1 2

White COM1_RXD 2 3

Red COM2_TXD 3 2

White COM2_RXD 4 3

Black COM1 GND 5 5

Black COM2 GND 5 5

White-Black MKI GND 5 MKI GND

White-Black ER GND 5 ER GND

White-Black PPS GND 5 PPS GND

Yellow CANI+ 6 CANI+

Green CANI- 7 CANI-

- NO CONNECT 8

Black PWR RET (GND) 9 BATT-

Blue EMD RADAR OUT 10 ER_OUT

White MAN MARK IN 11 MKI

Orange PPS 12 PPS

- NO CONNECT 13

Red PWR INPUT 14 BATT+



SAVECONFIG COMMAND

If you change the configuration of a function and want to save 
the new settings for your next session, use the SAVECONFIG 
command. 

CONFIGURING THE COMMUNICATION PORT

Use the COM command to configure the communication port 
through the command line. For example, to set COM port 2 to 
9600 bps, no parity, 8 data bits, 1 stop bit, no handshaking, echo 
off, and break detection on, enter the following:

com com2 9600 n 8 1 n off on

NMEA LOGS

To configure the receiver output through the command line:

1. Ensure the communication port is configured:

2. Select and configure the NMEA string that you want to 
output. For example, to log gpgga (position system fix data 
and undulation) at 2 Hz, enter the following:

log gpgga ontime 0.5

ENABLING SBAS POSITIONING

To enable SBAS positioning, enter the following command:

sbascontrol enable

Once enabled, the Solution type field shown in the Connect 
Position window changes from Single to SBAS, and you may 
see SBAS satellites in the Constellation window. SMART-MR10 
will track available SBAS satellites, including WAAS, EGNOS 
and other SBAS systems.

ENABLING GL1DE®

To enable GL1DE, enter the following commands:

pdpfilter enable

pdpmode relative auto

ENABLING Bluetooth WIRELESS TECHNOLOGY

Bluetooth wireless technology is configured on the SMART-AG 
COM3 internal port and is enabled by default.

To disable Bluetooth wireless technology:

btcontrol disable

To enable Bluetooth wireless technology:

btcontrol enable

For detailed information about the configuration and enabling of 
Bluetooth wireless technology on the SMART-AG, refer to 
Chapter 5 Bluetooth Configuration in SMART-AG User Manual.

USING THE CAN BUS

A CAN Bus is a serial bus that provides services for processes, 
data and network management. There is CAN Bus capability 
through the SMART-AG cable, see Table  on Page 1. 

NMEA 2000 is a CAN standard created by the National Marine 
Electronics Association and designed to support networking in 
marine applications. It functions over a longer physical distance, 
and supports more physical nodes than ISO 11783. The 
relationship between NMEA2000 and SAE J1939 is that J1939 
is the standard, while the NMEA 2000 group has added some 
new messages (called PGNs or Parameter Group Numbers) 
and added a new, additional transport protocol called 
FastPacket. NMEA2000 compliant, for all intents and purposes, 
means J1939 compliant plus support for new NMEA2000 
messages. In other word, one cannot have NMEA2000 without 
J1939 support as well. J1939 is additionally “harmonized” with 
ISO 11783, a standard for the agriculture industry.

The CAN module is generally not user-interactive.It is activated 
by entering the command SETCANNAME 305. If this is followed 
by entering the SAVECONFIG command, the CAN module is 
activated immediately on all subsequent start-ups. The module 
supports NMEA2000 Parameter Group Message (PGN): PGN 
129029 GNSSPositionData, PGN 129025 
GNSSPositionRapidUpdate, and PGN 129026 
COGandSOGRapidUpdate.

EMULATED RADAR (ER)

The SMART-AG provides an emulated ground speed RADAR 
pulse output. The enclosure outputs ER via the bare wires 
labeled ER GND and ER_OUT on the SMART-AG cable. See 
Table  on Page 1 for the pin-out details of this cable. Also see 
Appendix B.5  RADARCFG of the SMART-AG User Manual.

The ER outputs a logic high of 6.3 V minimum and logic low of 
1.5 V maximum with a rise and fall time of less than 1 ms. Its 
output references battery GND when output is logic low and 
provides logic low output until its speed is greater than 1 km/Hr. 

It provides an output frequency that represents 26.11 Hz/km/Hr 
with an effective range from 1 km/Hr to 55 km/Hr and uses 2D 
velocity for near-horizontal applications.

TERRAIN COMPENSATION

The optional SMART-AG Terrain Compensation feature corrects 
for errors in position caused by rolling of the vehicle. The 
SMART-AG senses the vehicle’s roll angle and, with the user-
entered “height above ground”, compensates the position output 
to give the position under the vehicle rather than at the antenna. 
Once configured, corrected positions are sent to host 
equipment. See the Appendix B.4 $PMDT of the SMART-AG 
User Manual.

For proper operation, SMART-AG requires proper installation, 
accurate height setting and levelling of the tilt sensor.

LOGGING DATA

An extensive collection of logs has been created to capture the 
data your SMART-AG receives and processes. These logs can 
be directed to a SMART-AG port (COM1 or COM2) and can be 
automatically generated when new or changed data becomes 
available or at regular intervals. The available logs are listed in 
the OEMV Family Quick Reference Guide.

To log data, use the LOG command. For example, to log the 
pseudorange position to COM 2 every 30 seconds, enter the 
following:

LOG COM2 PSRPOS ONTIME 30

When requesting logs, you can request the output data in three 
formats:

• ASCII 

• Abbreviated ASCII 

• Binary 

Abbreviated ASCII is the best format to use when you want to 
work with the receiver directly and review individual log contents 
visually.

 When using Connect to configure your receiver, ensure all 
of the graphical windows are closed before you issue the 
SAVECONFIG command.



Refer to the OEMV Family Firmware Reference Manual (OM-
20000094) for information on the LOG command, specifying the 
output format, and the detailed contents of each log. 

If you prefer, Connect provides a graphical interface for 
configuring data logging. Select Logging Control Window from 
the Tools menu. In the Logging Control window, you can select 
which logs to capture and choose to which ports to send the 
data. In addition, you can specify a file in which to save the data.

When logging data through Connect, close all unused graphical 
windows to save COM port throughput and receiver CPU usage.

QUESTIONS OR COMMENTS

If you have any questions or comments regarding your   
SMART-AG please contact NovAtel using one of these methods:

Email: support@novatel.com

Web: www.novatel.com

Phone: 1-800-NOVATEL (U.S. & Canada)
1-800-668-2835
1-403-295-4900 (International)

Fax: 1-403-295-4901

NovAtel, GL1DE and OEMV are registered trademarks of NovAtel Inc.

SMART-AG is a trademark of NovAtel Inc.

The Bluetooth® word mark and logos are registered trademarks owned by 
Bluetooth SIG, Inc. and any use of such marks by NovAtel Inc. is under license. Other 
trademarks and trade names are those of their respective owners.

Windows is a registered trademark of Microsoft Corporation.

Tyco is a trademark of Tyco Electronics Corporation.
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